You need to Read the rules and Join the forums before you can post.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ATI/AMD Driver issues
04-17-2011, 10:45 AM,
#1
ATI/AMD Driver issues
Hey guys,

I'm having quite a bit of trouble with my video card's drivers. I had already installed drivers from the CD that came with my video card, but I wanted to update them to the most recent. So I went to AMD's website and downloaded/installed the ones that were for my graphics and OS. After the installation, the display driver wasn't registering. Now I keeps telling me I have no display driver and something called Hydra won't work correctly without it. I've tried reinstalling the drivers from the disk, but it doesn't do anything. I really would appreciate some help here. Thanks for future replies Smile
Reply
04-17-2011, 11:34 AM,
#2
RE: ATI/AMD Driver issues
Uninstall all the currently installed drivers, then go to the website, get the latest driver, install it.
Your friendly forum administrator.
Reply
04-17-2011, 11:39 AM,
#3
RE: ATI/AMD Driver issues
Well I did, I went to device manager and hit uninstall and the video device disappeared, so i went to dl the latest drivers and it still didn't do it.
Reply
04-17-2011, 11:58 AM, (This post was last modified: 04-17-2011, 11:58 AM by Andrew J.)
#4
RE: ATI/AMD Driver issues
Go into Control Panel, Add/Remove Programs and find then uninstall the driver(s).
Your friendly forum administrator.
Reply
04-17-2011, 12:38 PM,
#5
RE: ATI/AMD Driver issues
Ok I did so and dl it again and it seemed to have worked Smile It's not showing any error message and its letting me go up to 1920x1080 again. Thanks as always!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)