You need to Read the rules and Join the forums before you can post.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Power Supply Fan not turning on - New Build
02-04-2012, 09:13 AM, (This post was last modified: 02-04-2012, 11:11 AM by pedwards.)
#1
Power Supply Fan not turning on - New Build
I assume that's a death sentence no? I tried an out of case test with all my components, and the power supply looked like it didn't do a thing. Didn't smell anything. The fan didn't turn on. Nothing on the motherboard lit up. I even changed the main power cable with one from my old PC. Nothing. Unplugged all the components and tried again. Nothing.

It's a SeaSonic Platinum-1000 1000W 80 PLUS Platinum Modular. I tried switching it on / off several times to "reset" it.. still no life from it.

What luck. 2 weeks to get this stuff in, and now this happens. Sad

1.) If you were me, would you go out to get a store bought one to continue testing? Or wait the 1 week to wait for the whole exchange process to happen again ( I do have a year warranty on the machine).

My only concern is I will wait one week and find something else defective. For a weekend project, turning into a month long one.

2.) If I do decided wait for exchange, how should I store my mobo? I have the siverlight heatsync attached, so not willing to unattach that. Should I screw it into the case? So I just leave it covered somewhere?

Thanks much
CPU: Intel i7-2600K @4.2GHz Mobo: ASRock P67 EXTREME4 GEN3 RAM: Corsair Vengence 8GB 1600Mhz DDR3 GPU: Sapphire Radeon HD 7970 3GB
SSD: Samsung 830 Series 256GB SATA 6.0Gb/s HDD: Seagate Barracuda 1TB PSU: SeaSonic Platinum-1000 80 PLUS Modular ODD: SONY DVD 24x
CPU Cooler: Thermalright SilverArrow Sound: Creative SB X-Fi Titanium Fatal1ty PCI-E Case: CM Storm Trooper
Reply
02-04-2012, 01:44 PM,
#2
RE: Power Supply Fan not turning on - New Build
Quick checks:
24 pin connection to mobo.
8 pin connection to cpu.
Switch on PSU is ON.
If its connected to a volt protection switch to ON.
Try with just CPU RAM and MOBO.

mmm, thats all i can think of.
Desktop: CPU: Intel Core i5 2500 3.30GHz RAM: G.Skill 8GB MOBO: ASRock P67 Extreme4 Gen3 Video Card: SLI MSI Nvidia GeForce GTX 460 768 SSD: Corsair Force 3 60GB HDD: Samsung F3 1TB Sound: Creative Sound Blaster X-Fi Titanium Mouse: Storm Sentinal Z3RO-G Keyboard: Das Keyboard Silent/Filco Majestouch 2 Speakers: Behringer MS-16 Headphones: Alessandro MS-1/Shure SRH440 modded Router: D-Link Xtreme DIR-655 Monitor: Dell Ultrasharp U2312HM De-anti-glared Laptop: Lenovo Thinkpad X120e/Thinkpad T430
Reply
02-05-2012, 09:02 AM,
#3
RE: Power Supply Fan not turning on - New Build
If your mobo has one, use the clear CMOS button or the MemOK button. If it still doesn't work call them for help.[/align]
Dota 2 Beta Tester
Extreme Starcraft II Geek
Still studies Calculus BC in Freshman year..
Reply
02-05-2012, 10:37 AM,
#4
RE: Power Supply Fan not turning on - New Build
if it is an easy take back then do it. The walk will do you good.
If not. Crap. Cable changes and test with yours and others. a friends or to work... just don't blame me for anything that blows up.
Always best to let other do serious testing when it comes to actual power supplies.
CPU: Intel i7 2600k OC 4.2ghz.Cooler: ASUS silent Warrior.Mobo: Gigabyte GA-Z68A-D3H-B3.Graphics Card: XiShi HIS 6970 IceQ.RAM: G.SKILL Ripjaw DDR3 1600 2x4Gb.SSD: OCZ Solid 3 120Gb.HDD: WD green disk 2TB.PSU: OCZ 850W 80PLUS Gold.Case: Something Chinese, still good.monitors:Samsung B2230H 21.5-inch. LG 42 inch HDTV. All very quiet.
Reply
02-05-2012, 04:23 PM,
#5
RE: Power Supply Fan not turning on - New Build
Figured it out. I forgot to push the stupid power button on the mobo given the graphics card was covering it. D'ohh!

If it was in a case, I'd be like duh... push the power. For some reason I expected doing an out of box test to magically power on.

Whoops! Thanks for all the help! Blush
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)