You need to Read the rules and Join the forums before you can post.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Power supply question
10-22-2011, 09:38 AM, (This post was last modified: 10-22-2011, 09:39 AM by compy_noob.)
#1
Power supply question
So, I'm building a Tier 1 gaming pc as seen on this site.

I did modify a couple of things - upgraded the hard drive to the Tier 2, 1 TB hard drive and upgraded the motherboard to the future-proof-sounding ASRock Z68 Extreme3 Gen3 LGA 1155 SATA6Gb/s USB3.0 (the INTEL alternative given in the article).

Aaanyways. I installed the CPU, RAM and video card and plugged the motherboard into the power supply so that I could try a boot. No dice. The motherboard has a handy on / off button, but no fans come on, nothing.

Here's what's plugged in -

Power supply -> outlet
Motherboard -> Power supply (via 24 pin ATX)
Video card -> Power supply (via the PCI E -labeled cable)
Top fan of the case -> Power supply


Nothing turns on or spins.

I'm going to grab a voltmeter from school and see if anything is coming off of the power supply. I think I just have a dud. Any other ideas?

Thanks in advance!
Also, while I am a newbie, I did flip the switch on the back of the power supply ;-)
Reply


Messages In This Thread
Power supply question - by compy_noob - 10-22-2011, 09:38 AM
RE: Power supply question - by Andrew J - 10-22-2011, 10:05 AM
RE: Power supply question - by compy_noob - 10-22-2011, 10:29 AM
RE: Power supply question - by Andrew J - 10-22-2011, 11:40 AM
RE: Power supply question - by MathieuB - 10-22-2011, 03:21 PM
RE: Power supply question - by compy_noob - 10-22-2011, 04:53 PM
RE: Power supply question - by MathieuB - 10-22-2011, 05:16 PM
RE: Power supply question - by compy_noob - 10-22-2011, 05:19 PM
RE: Power supply question - by compy_noob - 10-22-2011, 06:46 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)