You need to Read the rules and Join the forums before you can post.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble with BF:BC2
07-19-2011, 11:37 AM,
#1
Trouble with BF:BC2
I've been playing bad company 2 for awhile now and im just not getting good frame-rates.
My specs:
-Intel Pentium E6300 dual core 2.8Ghz
-4GB DDR2 RAM
-PNY Nvidia GTS 250
-WD 500GB 7200rpm HDD

-22" monitor 1680x1050 res

I know my rig aint much but I know it can run the game on at least medium, can anyone suggest anything like settings in the NVidia control panel or anything else to improve my frame-rates, they seem to be getting me killed a lot lately...
<insert clever sig>
Reply
07-19-2011, 12:46 PM,
#2
RE: Trouble with BF:BC2
What frame rates are you getting? Also what are the settings you are using? I saw you say at least medium, is that what you currently run at?
Here are some links you may find useful.
Forum Rules - Introduce Yourself - Things to know before asking a question
Reply
07-19-2011, 01:05 PM,
#3
RE: Trouble with BF:BC2
Turn off anti-aliasing and vsync.
Your friendly forum administrator.
Reply
07-19-2011, 01:24 PM,
#4
RE: Trouble with BF:BC2
I already have Vsync and anti-aliasing off, everything is set at medium and i have disable Bloom and HBAO in the config file, i have also set the DX version to 9 (supposedly helps). My frame rates are were around 15-25, went way down if and explosion happens or destructible environment event occurred near me.

So I pondered this issue and checked my specs in speccy(system analyzer made by Piriform, same guys who make CCleaner) real quick just so see what everything was running at. I saw that my both of my CPU clocks were at 1600Mhz, but i have a 2.80Ghz processor. So i then proceeded to look at my bios settings. For the record i know how to do basic things in the bios, but as far as changing system frequencies and such i have little knowledge. anyway turns out my system frequencies were set on "manual" and everything under it was set on normal. i loaded the optimized defaults and then switched it from manual to "auto" and booted my machine. Speccy said everything was running at the speed it should. Problem solved i thought. half hour later i checked my speeds in speccy and it said my multiplier was only at 6.0, when it should be at 10.5, after searching on the internet i found that most LGA 775 mobo's have a feature called "Speedstep" (something intel made i guess) and it underclocks your processor when its not working at full load, but clocks it back when it needs it. so i started up bad company and BAM! 45+ FPS.

this whole time my BIOS was misconfigured......

anyway so i think i got everything fixed but i wanna ask, should i disable SpeedStep?

and 1 last thing, i know your very busy Mathieu but a small article on proper BIOS settings for gaming computers would be great Smile
<insert clever sig>
Reply
07-19-2011, 01:29 PM,
#5
RE: Trouble with BF:BC2
Okay I'm glad that you fixed your issue but your capitalization makes newborn kittens want to die...
Reply
07-19-2011, 01:32 PM,
#6
RE: Trouble with BF:BC2
Glad you fixed your problem.

(07-19-2011, 01:29 PM)Grammer Nazi Wrote: Okay I'm glad that you fixed your issue but your capitalization makes newborn kittens want to die...

I enjoyed the irony in your username.
Your friendly forum administrator.
Reply
07-19-2011, 09:17 PM,
#7
RE: Trouble with BF:BC2
Speed step helps you save some power. Why would you want to disable it? Your CPU only underclocks when you don't need that much for it and it goes back up to normal speed when there's a demand.
Laptop: MacBook Pro 13"
Case: Drawer turned to case CPU: Intel Core i3 2100 CPU Cooler: Stock brah GPU: EVGA GTX 460 HDD: Corsair Nova 32GB Motherboard: GA-Z68MA-D2H-B3 Z68 RAM: Ripjaw 8GB 1600 Optical Drive: Don't need PSU: 620W Antec Neo ECO. Operating System: OS X Lion/ Windows 7x64
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)