You need to Read the rules and Join the forums before you can post.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Power Supply Fan not turning on - New Build
02-04-2012, 09:13 AM, (This post was last modified: 02-04-2012, 11:11 AM by pedwards.)
#1
Power Supply Fan not turning on - New Build
I assume that's a death sentence no? I tried an out of case test with all my components, and the power supply looked like it didn't do a thing. Didn't smell anything. The fan didn't turn on. Nothing on the motherboard lit up. I even changed the main power cable with one from my old PC. Nothing. Unplugged all the components and tried again. Nothing.

It's a SeaSonic Platinum-1000 1000W 80 PLUS Platinum Modular. I tried switching it on / off several times to "reset" it.. still no life from it.

What luck. 2 weeks to get this stuff in, and now this happens. Sad

1.) If you were me, would you go out to get a store bought one to continue testing? Or wait the 1 week to wait for the whole exchange process to happen again ( I do have a year warranty on the machine).

My only concern is I will wait one week and find something else defective. For a weekend project, turning into a month long one.

2.) If I do decided wait for exchange, how should I store my mobo? I have the siverlight heatsync attached, so not willing to unattach that. Should I screw it into the case? So I just leave it covered somewhere?

Thanks much
CPU: Intel i7-2600K @4.2GHz Mobo: ASRock P67 EXTREME4 GEN3 RAM: Corsair Vengence 8GB 1600Mhz DDR3 GPU: Sapphire Radeon HD 7970 3GB
SSD: Samsung 830 Series 256GB SATA 6.0Gb/s HDD: Seagate Barracuda 1TB PSU: SeaSonic Platinum-1000 80 PLUS Modular ODD: SONY DVD 24x
CPU Cooler: Thermalright SilverArrow Sound: Creative SB X-Fi Titanium Fatal1ty PCI-E Case: CM Storm Trooper
Reply


Messages In This Thread
Power Supply Fan not turning on - New Build - by pedwards - 02-04-2012, 09:13 AM

Forum Jump:


Users browsing this thread: 1 Guest(s)