You need to Read the rules and Join the forums before you can post.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
headset mic not working
05-03-2011, 07:52 AM, (This post was last modified: 05-03-2011, 07:56 AM by GIMJ.)
headset mic not working
A bit over a month ago I bought a steelseries siberia v2 (non usb version). It was working well until yesterday. I was talking with some friends on mumble and they went away for about a half an hour. When they came back my mic no longer registered me speaking into it. In the time that they were gone I didn't drop or damage the headset in any way and I have never had any indication (static etc..) of a loose connection.

I tried reinstalling my audio drivers but that didn't work. Then I noticed that in control panel under sound properties where you can see the green bars when the microphone device is picking up sound it was doing nothing. However it shows the bars when I plug and unplug the mic meaning that it is not the cord or the sound card but the mic.

I tried plugging the headset into my laptop and had the same problem. It is too late for me to RMA it to newegg and it would cost me almost as much as the headset is worth to send it back to steelseries to get it replaced.

So I was wondering if anyone has any ideas as to what the problem could be and if there is a way I could fix it. I opened up the mic and the volume control and didn't see any broken wires.


Forum Jump:

Users browsing this thread: 1 Guest(s)