HR Forums
New build won't turn on. - Printable Version

+- HR Forums (http://forums.hardware-revolution.com)
+-- Forum: Computer Building (http://forums.hardware-revolution.com/forumdisplay.php?fid=9)
+--- Forum: Troubleshooting (http://forums.hardware-revolution.com/forumdisplay.php?fid=12)
+--- Thread: New build won't turn on. (/showthread.php?tid=4108)



New build won't turn on. - Liamz - 06-19-2013

So I build my computer and tried to turn in on, and nothing happened. No lights, fans, or beeps. I made sure all the connectors were secure so I don't know what to do. Any advice?

P.s. I wore an anti-static band and hit the case so I don't think it's static.


RE: New build won't turn on. - Liamz - 06-20-2013

(06-19-2013, 10:10 PM)Liamz Wrote: So I build my computer and tried to turn in on, and nothing happened. No lights, fans, or beeps. I made sure all the connectors were secure so I don't know what to do. Any advice?

P.s. I wore an anti-static band and hit the case so I don't think it's static.

Ok so after further inspection two little LED lights come on my motherboard when the power in plugged in and the switch flipped. So that's something. My guess is I incorrectly wired the start button so it won't turn on. Does this sound accurate?


RE: New build won't turn on. - ichigeki - 06-20-2013

Yea, it can be tricky to plug those little wires in. Make sure they go in correctly. You can also try to short the two pins to start up the computer.


RE: New build won't turn on. - Liamz - 06-20-2013

Sorry I never replied. I was able to figure it out and my new computer is amazing! Thanks to everyone who answered my questions in the past!


RE: New build won't turn on. - ichigeki - 06-20-2013

No problem. Keep us posted on how it runs and if you run into any issues.


Re: New build won't turn on. - Phrosty - 06-20-2013

Make sure you post some pictures too. :-) we looked to ogle new rigs. Lol

Sent from my HTCONE using Tapatalk 2