HR Forums

Full Version: New Build Locking Up... How I Diagnose?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Hi all,

I just built Mathieu's Tier 2 budget gaming PC. You can find it in this article:

I have all the Tier 2 hardware, except for the Cooler Master Hyper 212 Plus cpu cooler. I have it here in the box, but am currently using the stock cooler because the part came late and I couldn't resist building the PC.

It's been up and running I think exactly 2 weeks to the date. It's performed amazingly and I haven't had any problems with it until a day or two ago. It began locking up during games that I had previously had no problems with. It would just freeze during gameplay and occasionally the sound would be caught in some sort of loop. I thought it was a game issue, but installed another game and it happened there.

A friend suggested it might be issues with voltage drop in my apartment. He suggested getting a UPS which I haven't done yet because I haven't diagnosed the problem for sure. I did notice the PSU has sort of a loose connection between the cord and the PSU itself. Seems sort of flimsy. Once after a crash, the PC would not reboot. I would hear it start up, and the fans would light up and all, but no lights would come on on the keyboard and nothing would happen on the monitor. I unplugged and firmly reseated the cord to the PSU, and the computer started again.

Things seemed fine, but I quickly began to have problems again. I began fiddling with drivers; motherboard, audio, and video. Things got a little weird but it didn't seem to change the problem. Last night I reformatted the hard drive, reinstalled windows, and reinstalled all of the latest drivers for all the hardware.

I was just now on the internet and took a phone call. When I returned, the PC was totally locked up again. Cursor frozen, no response, but screen still on display, frozen. This is the first time I had a freeze that was not during an intensive moment of gaming.

Please, can somebody help me? What steps should I take to pinpoint exactly what the problem is? I hope I don't have a bad part! I really need to tackle this issue and get it firmly resolved, so I hope that one of you will extend yourself to help point me in the right direction.

Thank you very much.
Well someone is probably going to have a more detailed approach, but I would first ask are there any spare parts you have or you can borrow (a PSU you KNOW works fine?).

Because maybe step one if you suspect the PSU would be to test the system out with one you know works and seeing if it has any issues.

Many times faulty PSUs will power the fans and other things fine but won't power the main components like they should.

Usually people don't have a spare PSU though so there are other options.

If you have access to the right tool you can actually test the PSU for voltage and power but you probably do not.

The usual approach to trouble shoot a PC like this is to take it down to the bare minimum (cpu, mobo and memory) and add components one by one until you find one that makes it stop working.

I do not have a spare PSU, nor do I have a multimeter or other such tool that I can test it with.

I am new to building computers. I don't know how to test these things and isolate the problem, nor am I totally sure the PSU is the problem. What I detailed in my post was mainly a friend's hypothesis, and I am pretty confused about the whole thing.

The motherboard does not have onboard video so I can't strip it down to cpu, motherboard, and memory. Also, the freezes are random and I wouldn't know how to induce one. On the day they began, they happened a number of times, and in fairly rapid succession. As for today, I hadn't had one since yesterday afternoon, and today's was at 6:30 PM. So that would be sort of a trial and error method.

Those are all reasonable suggestions, I just don't really know what to do or how to diagnose the problem, or what I might do when we get there.
This could be due to a few issues, here's what I'd check first:

It could be due to overheating (unlikely, but it's good to check first):
Use a program like Speedfan to monitor your CPU temperature when you're gaming
Do the same thing with the AMD Catalyst Control Center, to monitor the temperature of your video card.

It could be faulty RAM: Run MemTest86+ :
see if you get any errors

Let me know what you get from that.
Thanks Mathieu.

I just downloaded Speedfan. I've been using Core Temp for a while, and it has reported my CPU at a max of 25C during gaming sessions.

Catalyst Control Center reports my GPU temp at 39-40C while I am browsing, using Windows, and writing this post. It reports the fan speed at 37-38%. The activity has read 0-4% while I am doing these basic activities.

Here are the readings from Speedfan, during basic usage:

System: 30C
CPU: 33C
AUX: 111C (There is a flame for this icon.. what is this AUX?)
HD0: 27C
Core: 20C

I just ran MemTest86+ and went through one full pass. It took about 30 minutes and reported 0 errors.

I have yet to check the reports from CCC and Speedfan during a gaming session. I should be able to get some gaming in tomorrow, and report the readings then.
I want to add one more thing... The other day when I was playing around with drivers and making sure I had them all installed, I noticed something when I came to the motherboard drivers. I have downloaded the latest driver from ASRock, which is the AllIn1 Win7-64 8.71_WHQL. This adds a number of drivers to the machine. One of these is North Bridge Filter Driver When I run the installer, it seems to add everything properly, and I see the install for the North Bridge Filter Driver running. But then if I open the driver installer again, when I highlight the North Bridge Filter Driver, it says "Current Version not Installed." It continues to do this. I don't know what a North Bridge is or if this could have anything to do with it, or what's going on here. But I thought I would add that.
Don't worry about that AUX reading, it's most likely an error.

You want temperature readings when gaming, when your system is stressed.

As for MemTest86+, let it run overnight, see what that gives you.

Here are my findings:

I ran Speedfan and Catalyst Control Center throughout several hours of playing X3: Terran Conflict on high settings, which can be a fairly demanding game. CCC reported my GPU temperature maxing at 50C, with a range of about 42-50C. Fan speed hovered at about 39%.

Speedfan's findings seemed to be about this:

System: 31C
CPU: 36C
Aux: 75C and over, rapidly fluctuating, leading me to believe that yes, this is some sort of error.
HD0: 26C
Core: 26C

The major discovery is with MemTest. I left it running last night when I went to bed, and awoke to find the computer frozen. The red "+" in "MemTest86+" was flashing, so whatever was going on on the monitor wasn't totally frozen, but the controls were locked up and the tests weren't running. The tests had run for 2:11:13, completed 2 passes, and generated 194 errors. It was frozen about halfway through Test #8.

What was really odd was that at the bottom of the screen, covering the section where the menu and controls normally appear, was a gigantic solid red rectangle. I have no idea what that means.

I powered the computer off and attempted to reboot it. Like I described in an earlier post, the fans came on, the computer seemed to power up, but nothing was happening on the monitor. Again on the advice of the friend who thought it was a power problem, I turned the computer off, switched off the power supply, unplugged the power cord for about 30 seconds, reseated it in the PSU, turned it back on, and the computer then booted up properly.

However, things did not proceed entirely normally. During startup, I got a message that said "CMOS Checksum bad- F2 to run setup, F1 to load default values." I hit F2, went into the BIOS, but didn't do anything and exited. Windows then loaded. My clock was all whacked out and set to some other time and date though, and I had to update it.

So yes, it looks like we've found something. Could you help me to interpret what all of this means for me and my system? Thanks!
Your temperatures are excellent, so that's not the issue here.

MemTest86+ errors mean that the problem is with your RAM. Simply RMA it for a new kit and that should resolve your problems.
Alright, will do! Thanks very much for the assistance.
I have a couple final concerns:

1) When I first booted the computer right after I assembled it, during startup there was some message about BIOS or CMOS settings being wrong or bad or something.. I never reset it or went into the bios and set everything to default. I don't know much about BIOS/CMOS settings so decided not to fiddle with it.

I was just doing some reading about RAM and how it goes bad. I did some reading about "DRAM voltage." I read the back of my G. Skill box (that I am going to send the RAM back in now that the RMA is approved), and it said CL 9-9-9-24 1.5V. I checked the BIOS out of curiosity, and the 9-9-9-24 timing were set properly. However, the DRAM voltage said 1.65 [AUTO], whereas the G. Skill box says 1.5V.

What is the significance of this? Was my RAM's voltage set too high to begin with? Could this have damaged the RAM? Would it operate correctly if I set it down to 1.5V, or is the RAM already messed up?

2) I am currently using my laptop because this evening I had another crash. I ran into the situation I've described where most of the computer seems to power on, but it's not booting up. Nothing I did could cause the computer to boot. I even tried using one stick of RAM at a time, in case one stick was the "problem" stick and preventing me from booting. Nothing worked.

Given that it has been 2 weeks since I received the parts, and I am RMA-ing the RAM, I would like to know if there's a chance this situation could be due to other faulty parts or something. Is it the bad RAM that would be causing my computer not to boot? I just want to be sure I don't miss my mark for the RMA period if anything else is wrong. I will be mailing the RAM back to NewEgg tomorrow.
Pages: 1 2 3