HR Forums

Full Version: defective video card?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm putting together a computer for the first time(tier 2) and after much frustration finally got it running, but without the video card plugged into the power supply. As soon as i plug it in, it starts up for a millisecond before shorting out. What say you?
Welcome to the forums!

Try following these steps to see if it helps:

1. Unplug all power connections and turn your power supply to the sign (off).
2. Remove the video card.
3. Reinstall it firmly making sure not to take any wires with it.
4. Connect 2 of the 6 pin power connectors firmly into the video card.
5. Connect the 24 pin mobo power.
6. Then the 8 pin cpu power.
7. Move the cables around making sure its not touching anything its not supposed to.
8. Now turn your power supply back on and try again.

When you say as soon as you plug it in, do you mean that you don't have to press the power button and it automatically boots?


list all of the parts in your build.....
-Intel Core i3-2120 Dual-Core + HyperThreading 3.3GHz
-BIOSTAR H61MGC Intel H61 LGA1155
-G.Skill 8GB (2 x 4GB) DDR3 1333MHz
-Gigabyte Geforce GTX 560 Ti Dual fans
-Seagate Barracuda ST500DM002 500GB SATA III
-LG SATA 22X DVD Burner
-Rosewill HIVE 550W 80 PLUS Bronze Modular
-Rosewill GEAR X3 Gaming ATX Mid Tower Computer Case
(02-21-2012, 12:00 AM)ichigeki Wrote: [ -> ]Welcome to the forums!

Try following these steps to see if it helps:

1. Unplug all power connections and turn your power supply to the sign (off).
2. Remove the video card.
3. Reinstall it firmly making sure not to take any wires with it.
4. Connect 2 of the 6 pin power connectors firmly into the video card.
5. Connect the 24 pin mobo power.
6. Then the 8 pin cpu power.
7. Move the cables around making sure its not touching anything its not supposed to.
8. Now turn your power supply back on and try again.

When you say as soon as you plug it in, do you mean that you don't have to press the power button and it automatically boots?

Thanks. Yes, I do have to press the power button.

When you have the PSU plugged into the video card after pressing the power button, does the fan begin to spin?
If you plug your monitor into the video ports on your motherboard, does your PC boot?
(02-21-2012, 10:56 PM)MathieuB Wrote: [ -> ]If you plug your monitor into the video ports on your motherboard, does your PC boot?

No, I have no signal.


(02-21-2012, 10:47 PM)ichigeki Wrote: [ -> ]When you have the PSU plugged into the video card after pressing the power button, does the fan begin to spin?

no
Either your motherboard is not properly installed and is getting shorted or it is defective.

Re-install the motherboard, pay attention to the standoffs, do not overtighten the screws attaching the motherboard to the standoffs, do not use plastic/paper washers.

If after that you still get the same problem, exchange your motherboard.
You could also get a bunch of cardboard and carefully lay your motherboard and parts on the cardboard making sure nothing touches something it shouldn't and try to boot up that way to see if its shorting or a faulty motherboard. Sorry run on sentence...